MPUG Central Indiana Chapter Meeting
– Microsoft Project Scheduling Theory
February 10th, 2009
Chris Oxtoby, MCP
Principal Consultant, Pcubed
Agenda

- Terminology and the Scheduling Equation
- Task Types
- Effort Driven Scheduling
- Smart Tags, Change Highlighting and Task Drivers
- Microsoft Project Settings
- Examples and Demonstration
- Best Practices
- Q & A
About Pcubed

Our Origins

Established 1994, 350 consultants worldwide

Our Clients

- Global leaders in helping organizations conceive, manage and deliver the most challenging projects
- Over 950 clients in the private and public sector, including over 100 of the Fortune 500

Our Partners

- Microsoft Gold Certified Partner
- IIL (International Institute for Learning, Inc.)
- TPG (The Project Group)
- EPK Group
- Associates

Our Approach

Guardian | Partner
---|---
Enabler | Coach

Influence | Capability
Terminology

- **Task**
  - An *activity* that needs to be accomplished within a defined period of time on a *project*.

- **Resource**
  - People, Facilities, Materials and Equipment that work on a *project*.

- **Assignment**
  - The *allocation* of the resource to a *task*.
Assignments

**Assignment = Task + Resource**

- By default, no work is associated with tasks in Microsoft Project until resources are assigned.

- Without resources, a task initially includes only an *estimate* of how long the task should take to complete.
Duration, Work and Units

**Duration** = The total *span* of active working time for either a task or the project.

**Work** = *Effort* or *people-hours* required to complete an assignment.

**Units** = Percentage of *available utilization* of a resource.
Scheduling Equation

\[
\text{Work} = \text{Duration} \times \text{Units}
\]

By default, Tasks without a resource have estimated Duration with **No Work**
Task Types

As previously discussed, tasks innately have three interrelated variables: Duration, Work, and Units. A change in one of these affects the other two variables.

For each task, MS Project stipulates the fixing of one variable, while the other 2 are updated. By default tasks are set to Fixed Units.
### Affects of Changing Assignment Values

<table>
<thead>
<tr>
<th>Setting</th>
<th>Fixed Work (Not effort driven)</th>
<th>Fixed Duration</th>
<th>Fixed Units (Default)</th>
</tr>
</thead>
<tbody>
<tr>
<td>User Action</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>You change Work</td>
<td>Duration changes</td>
<td>Units change</td>
<td>Duration changes</td>
</tr>
<tr>
<td>You change Duration</td>
<td>Units change</td>
<td>Work changes</td>
<td>Work changes</td>
</tr>
<tr>
<td>You change Units</td>
<td>Duration changes</td>
<td>Work changes</td>
<td>Duration changes</td>
</tr>
</tbody>
</table>

**MS Project has a bias to change:**
- Duration First
- Work Second
- Units Last
# Affects of Changing Assignment Values

<table>
<thead>
<tr>
<th>User Action</th>
<th>Setting</th>
<th>Fixed Work (Not effort driven)</th>
<th>Fixed Duration</th>
<th>Fixed Units (Default)</th>
</tr>
</thead>
<tbody>
<tr>
<td>You change Work</td>
<td>Duration changes</td>
<td>Units change</td>
<td>Duration changes</td>
<td></td>
</tr>
<tr>
<td>You change Duration</td>
<td>Units change</td>
<td>Work changes</td>
<td>Work changes</td>
<td></td>
</tr>
<tr>
<td>You change Units</td>
<td>Duration changes</td>
<td>Work changes</td>
<td>Duration changes</td>
<td></td>
</tr>
</tbody>
</table>
Affects of Changing Assignment Values

<table>
<thead>
<tr>
<th>Setting</th>
<th>Fixed Work (Not effort driven)</th>
<th>Fixed Duration</th>
<th>Fixed Units (Default)</th>
</tr>
</thead>
<tbody>
<tr>
<td>User Action</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>You change Work</td>
<td>Duration changes</td>
<td>Units change</td>
<td>Duration changes</td>
</tr>
<tr>
<td>You change Duration</td>
<td>Units change</td>
<td>Work changes</td>
<td>Work changes</td>
</tr>
<tr>
<td>You change Units</td>
<td>Duration changes</td>
<td>Work changes</td>
<td>Duration changes</td>
</tr>
</tbody>
</table>
Effort Driven Scheduling

• Effort driven scheduling assumes that a given task will require less time to complete as *incremental* resources are assigned to that task. (i.e. task is driven by the amount of effort or man-hours applied.)

• As incremental resources are added, total hours are kept constant and are distributed evenly across all resources.
Effort Driven Scheduling – Cont.

- You can see below that the work has remained the same. But the duration is different.
Aspects of Effort Driven Scheduling

- The effort-driven calculations will apply only after the first resource(s) assigned.
- The total work for the task will remain unchanged as resources are added or removed.
- Project will extend or shorten the duration of the task or adjust available units to accommodate the addition or removal of resources.
**Work and Duration**

**With Effort Driven**

**Assume:**
- Task duration = 2 weeks (80 hours)
- Assign a resource at 100% units
- Work = 80 hours

\[
\text{Duration} \times \text{Units} = \text{Work} \\
80 \times 1 = 80
\]

Assign a second resource at 100% units
- Task duration changes to 1 week (40 hours)
- Work remains at 80 hours

\[
\text{Duration} \times \text{Units} = \text{Work} \\
40 \times 2 = 80
\]

**Without Effort Driven**

**Assume:**
- Task duration = 2 weeks (80 hours)
- Assign a resource at 100% units
- Work = 80 hours

\[
\text{Duration} \times \text{Units} = \text{Work} \\
80 \times 1 = 80
\]

Assign a second resource at 100% units
- Task duration remains 2 weeks (80 hours)
- Work changes to 160 hours

\[
\text{Duration} \times \text{Units} = \text{Work} \\
80 \times 2 = 160
\]

* Default setting for most templates
Remember

- The effort driven status only comes into play when resources are added or deleted (not: Duration, Work, or Unit changes).
- You can leave the task type as a permanent attribute of the task. Alternatively, and you can change the task type temporarily at any time to control how Project treats a particular change in one of the work equation variables.
Smart Tags

- Displayed when Microsoft Project is given a possible ambiguous situation
  - Smart tags give you the ability to choose what action Microsoft Project should take.
  - It can override the default task type.
  - They appear as green triangles in a cell.
  - Click on the cell.
Smart Tags – Cont.

- When you click on the ⚠️ you are given choices to make:

  - The default is the choice Microsoft Project will make based on the task type.
Change Highlighting

- As you make changes to a schedule Microsoft Office Project recalculates the whole schedule. To make all changes more visible Microsoft Office Project 2007 can show them shaded (aqua by default).
  - Only the effects of the last change are shown.
  - Changes to text fields or certain backend fields, such as variance, are not highlighted.

- To turn on change highlighting select View>Show Change Highlighting.

- To turn off change highlighting select View>Hide Change Highlighting.

- The default is on.
This example shows the effect of changing the duration of task ID 2 from 15 days to 10 days.

The highlighting color can be changed by selecting Format>Text Styles…. Then select the item Changed Cells.
Task Drivers

- Microsoft Project can display Task Drivers to help you identify what determines the start date of the task.
- To display Task Drivers click Task on the Standard toolbar.

- Next, select the task you are interested in.
Task Drivers – Cont.

- You can also display the Task Drivers by select Project>Task Drivers

- This example shows that task ID 3 was selected with its Task Drivers displayed.
- The driver for this task is task ID 2.
Effort Driven Task Setting

Check the “Effort driven” box next to Task type:
Project > Task Information > Advanced
**Default Effort Driven Task Setting**

- The default setting for any new task added to the project can be set in: **Tools > Options > Schedule**
Default Smart Tag Setting

- Smart Tags can be turned on and off in: **Tools > Options > Interface**

![Options dialog box showing Smart Tag settings](image)
Example #1 – Task List

- The following example shows how fixing tasks, effort driven settings and resources work together. Let’s assume the following tasks with their names corresponding to their task types:

<table>
<thead>
<tr>
<th>Task Name</th>
<th>Duration</th>
<th>Work</th>
<th>Type</th>
<th>Effort Driven</th>
<th>Resource Names</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fixed Duration</td>
<td>4 days</td>
<td>0 hrs</td>
<td>Fixed Duration</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Fixed Duration Effort Driven</td>
<td>4 days</td>
<td>0 hrs</td>
<td>Fixed Duration</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>Fixed Units Effort Driven</td>
<td>4 days</td>
<td>0 hrs</td>
<td>Fixed Units</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>Fixed Units</td>
<td>4 days</td>
<td>0 hrs</td>
<td>Fixed Units</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Fixed Work</td>
<td>4 days</td>
<td>0 hrs</td>
<td>Fixed Work</td>
<td>Yes</td>
<td></td>
</tr>
</tbody>
</table>
Example #1 – Adding resources

- **Given**

<table>
<thead>
<tr>
<th>Task Name</th>
<th>Duration</th>
<th>Work</th>
<th>Type</th>
<th>Effort Driven</th>
<th>Resource Names</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Fixed Duration</td>
<td>4 days</td>
<td>0 hrs</td>
<td>Fixed Duration</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>2 Fixed Duration Effort Driven</td>
<td>4 days</td>
<td>0 hrs</td>
<td>Fixed Duration</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>3 Fixed Units Effort Driven</td>
<td>4 days</td>
<td>0 hrs</td>
<td>Fixed Units</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>4 Fixed Units</td>
<td>4 days</td>
<td>0 hrs</td>
<td>Fixed Units</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>5 Fixed Work</td>
<td>4 days</td>
<td>0 hrs</td>
<td>Fixed Work</td>
<td>Yes</td>
<td></td>
</tr>
</tbody>
</table>

- Since there are no resources assigned, there are no values in the work column. Now, let’s assign a resource to all these tasks:

<table>
<thead>
<tr>
<th>Task Name</th>
<th>Duration</th>
<th>Work</th>
<th>Type</th>
<th>Effort Driven</th>
<th>Resource Names</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Fixed Duration</td>
<td>4 days</td>
<td>32 hrs</td>
<td>Fixed Duration</td>
<td>No</td>
<td>1st Resource</td>
</tr>
<tr>
<td>2 Fixed Duration Effort Driven</td>
<td>4 days</td>
<td>32 hrs</td>
<td>Fixed Duration</td>
<td>Yes</td>
<td>1st Resource</td>
</tr>
<tr>
<td>3 Fixed Units Effort Driven</td>
<td>4 days</td>
<td>32 hrs</td>
<td>Fixed Units</td>
<td>Yes</td>
<td>1st Resource</td>
</tr>
<tr>
<td>4 Fixed Units</td>
<td>4 days</td>
<td>32 hrs</td>
<td>Fixed Units</td>
<td>No</td>
<td>1st Resource</td>
</tr>
<tr>
<td>5 Fixed Work</td>
<td>4 days</td>
<td>32 hrs</td>
<td>Fixed Work</td>
<td>Yes</td>
<td>1st Resource</td>
</tr>
</tbody>
</table>

- Note that values for work are now displayed
Example #1 – Changing Duration

- **Given:**

<table>
<thead>
<tr>
<th>Task Name</th>
<th>Duration</th>
<th>Work</th>
<th>Type</th>
<th>Effort Driven</th>
<th>Resource Names</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Fixed Duration</td>
<td>4 days</td>
<td>32 hrs</td>
<td>Fixed Duration</td>
<td>No</td>
<td>1st Resource</td>
</tr>
<tr>
<td>2 Fixed Duration Effort Driven</td>
<td>4 days</td>
<td>32 hrs</td>
<td>Fixed Duration</td>
<td>Yes</td>
<td>1st Resource</td>
</tr>
<tr>
<td>3 Fixed Units Effort Driven</td>
<td>4 days</td>
<td>32 hrs</td>
<td>Fixed Units</td>
<td>Yes</td>
<td>1st Resource</td>
</tr>
<tr>
<td>4 Fixed Units</td>
<td>4 days</td>
<td>32 hrs</td>
<td>Fixed Units</td>
<td>No</td>
<td>1st Resource</td>
</tr>
<tr>
<td>5 Fixed Work</td>
<td>4 days</td>
<td>32 hrs</td>
<td>Fixed Work</td>
<td>Yes</td>
<td>1st Resource</td>
</tr>
</tbody>
</table>

  - Here’s what will happen to these tasks when we change the duration from initial 4 to 2 days:

    | Task Name | Duration | Work | Type      | Effort Driven | Resource Names |
    |-----------|----------|------|-----------|---------------|----------------|
    | 1 Fixed Duration | 2 days  | 16 hrs | Fixed Duration | No | 1st Resource |
    | 2 Fixed Duration Effort Driven | 2 days  | 16 hrs | Fixed Duration | Yes | 1st Resource |
    | 3 Fixed Units Effort Driven | 2 days  | 16 hrs | Fixed Units | Yes | 1st Resource |
    | 4 Fixed Units | 2 days  | 16 hrs | Fixed Units | Yes | 1st Resource |
    | 5 Fixed Work | 2 days  | 32 hrs | Fixed Work | Yes | 1st Resource[200%] |

  - ⭐️ Duration changes! 1) Duration is entered & 2) Effort Driven task only applies to added or deleted resources
Example #1 – Changing Work

- Given:

<table>
<thead>
<tr>
<th>Task Name</th>
<th>Duration</th>
<th>Work</th>
<th>Type</th>
<th>Effort Driven</th>
<th>Resource Names</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Fixed Duration</td>
<td>4 days</td>
<td>32 hrs</td>
<td>Fixed Duration</td>
<td>No</td>
<td>1st Resource</td>
</tr>
<tr>
<td>2 Fixed Duration Effort Driven</td>
<td>4 days</td>
<td>32 hrs</td>
<td>Fixed Duration</td>
<td>Yes</td>
<td>1st Resource</td>
</tr>
<tr>
<td>3 Fixed Units Effort Driven</td>
<td>4 days</td>
<td>32 hrs</td>
<td>Fixed Units</td>
<td>Yes</td>
<td>1st Resource</td>
</tr>
<tr>
<td>4 Fixed Units</td>
<td>4 days</td>
<td>32 hrs</td>
<td>Fixed Units</td>
<td>No</td>
<td>1st Resource</td>
</tr>
<tr>
<td>5 Fixed Work</td>
<td>4 days</td>
<td>32 hrs</td>
<td>Fixed Work</td>
<td>Yes</td>
<td>1st Resource</td>
</tr>
</tbody>
</table>

- Here’s what will happen to these tasks when we change the work from initial 32 to 16 hours:

<table>
<thead>
<tr>
<th>Task Name</th>
<th>Duration</th>
<th>Work</th>
<th>Type</th>
<th>Effort Driven</th>
<th>Resource Names</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Fixed Duration</td>
<td>4 days</td>
<td>16 hrs</td>
<td>Fixed Duration</td>
<td>No</td>
<td>1st Resource[50%]</td>
</tr>
<tr>
<td>2 Fixed Duration Effort Driven</td>
<td>4 days</td>
<td>16 hrs</td>
<td>Fixed Duration</td>
<td>Yes</td>
<td>1st Resource[50%]</td>
</tr>
<tr>
<td>3 Fixed Units Effort Driven</td>
<td>2 days</td>
<td>16 hrs</td>
<td>Fixed Units</td>
<td>Yes</td>
<td>1st Resource</td>
</tr>
<tr>
<td>4 Fixed Units</td>
<td>2 days</td>
<td>16 hrs</td>
<td>Fixed Units</td>
<td>No</td>
<td>1st Resource</td>
</tr>
<tr>
<td>5 Fixed Work</td>
<td>2 days</td>
<td>16 hrs</td>
<td>Fixed Work</td>
<td>Yes</td>
<td>1st Resource</td>
</tr>
</tbody>
</table>

- Discussion
Example #1 – Changing Units

**Given:**

Here’s what will happen to these tasks when we **change the unit percentage** from initial 100 to 50%:

**Discussion**
Example #1 – Adding Additional Resources

- **Given:**

<table>
<thead>
<tr>
<th>Task Name</th>
<th>Duration</th>
<th>Work</th>
<th>Type</th>
<th>Effort Driven</th>
<th>Resource Names</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Fixed Duration</td>
<td>4 days</td>
<td>32 hrs</td>
<td>Fixed Duration</td>
<td>No</td>
<td>1st Resource</td>
</tr>
<tr>
<td>2 Fixed Duration Effort Driven</td>
<td>4 days</td>
<td>32 hrs</td>
<td>Fixed Duration</td>
<td>Yes</td>
<td>1st Resource</td>
</tr>
<tr>
<td>3 Fixed Units Effort Driven</td>
<td>4 days</td>
<td>32 hrs</td>
<td>Fixed Units</td>
<td>No</td>
<td>1st Resource</td>
</tr>
<tr>
<td>4 Fixed Units</td>
<td>4 days</td>
<td>32 hrs</td>
<td>Fixed Units</td>
<td>Yes</td>
<td>1st Resource</td>
</tr>
<tr>
<td>5 Fixed Work</td>
<td>4 days</td>
<td>32 hrs</td>
<td>Fixed Work</td>
<td>Yes</td>
<td>1st Resource</td>
</tr>
</tbody>
</table>

Here’s what will happen to these tasks when we **assign an additional resource** to these tasks (based on the initial setup):

<table>
<thead>
<tr>
<th>Task Name</th>
<th>Duration</th>
<th>Work</th>
<th>Type</th>
<th>Effort Driven</th>
<th>Resource Names</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Fixed Duration</td>
<td>4 days</td>
<td>64 hrs</td>
<td>Fixed Duration</td>
<td>No</td>
<td>1st Resource, 2nd Resource</td>
</tr>
<tr>
<td>2 Fixed Duration Effort Driven</td>
<td>4 days</td>
<td>32 hrs</td>
<td>Fixed Duration</td>
<td>Yes</td>
<td>1st Resource[50%], 2nd Resource[50%]</td>
</tr>
<tr>
<td>3 Fixed Units Effort Driven</td>
<td>2 days</td>
<td>32 hrs</td>
<td>Fixed Units</td>
<td>Yes</td>
<td>1st Resource, 2nd Resource</td>
</tr>
<tr>
<td>4 Fixed Units</td>
<td>4 days</td>
<td>64 hrs</td>
<td>Fixed Units</td>
<td>No</td>
<td>1st Resource, 2nd Resource</td>
</tr>
<tr>
<td>5 Fixed Work</td>
<td>2 days</td>
<td>32 hrs</td>
<td>Fixed Work</td>
<td>Yes</td>
<td>1st Resource, 2nd Resource</td>
</tr>
</tbody>
</table>

- **Discussion**
Example #2 – Task List with Resources Assigned

- If you have 3 different tasks representing different task types, each with the same duration assigned to a resource.
Example #2 – Resource Enters Fewer Hours

- If a resource enters less hours than scheduled, here’s what will happen to these tasks.

- In the same way, this is what will happen if a resource enters more hours than scheduled…
Example #2 – Resource Enters More Hours

- In the same way, this is what will happen if a resource enters more hours than scheduled.

- Note: Using the “Tracking Gantt View” provides a view of the baseline and changes in timing are easy to spot!
More on Assigning Resources

- When you prepare a list of resources in the Task Form and then assign them all at once, Project first calculates each of the task assignments...then it calculates the task duration to be equal to the longest duration needed by any one of the resources to complete it’s work.

- These resources are called “Driver Resources”.

- This is one reason for breaking large tasks down into smaller task durations of only a few weeks with only a couple of resources.
The “Driver Resource”

- A Driver Resource is a resource that must work for the full task duration to complete their work. (i.e. a bottleneck resource assigned to the task)

- A Non-driver resource may become a Driver resource if the duration is shortened enough or if their units are reduced enough.
So which Task Type Should I use?

- **Fixed Duration non Effort Driven**
  - On going (level of effort (LOE) tasks) Tasks
  - Estimate is based on dates and/or task durations

- **Fixed Work Effort Driven**
  - Discrete tasks
  - Estimate is based on work
Best Practices

- Check **Tools > Options > Schedule** before you start entering tasks.
- Use schedule templates with correct task types already defined.
- Watch for Smart Tags.
- During team/project meetings review upcoming work/tasks before time is getting posted to them and break larger tasks down into smaller manageable chunks.
- Keep durations from being too long, short or having many resources assigned to them. It will make the Project Manager’s life much easier.
Q and A

- Chris Oxtoby, MCP
  - chris.oxtoby@pcubed.com
  - +1 (260) 246-3827
For more information, please visit www.pcubed.com