Home Forums Discussion 99% completed project when all tasks are 100%

This topic contains 9 replies, has 3 voices, and was last updated by Daryl Deffler Daryl Deffler 1 month, 2 weeks ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #29221 Reply

    Jerry Insall
    Participant

    We are struggling with schedules with Budget Resources.  If a schedule has a budget resource(s) (baselined) and all schedules are statused to 100%, the zero level shows 99%.  If I delete the budget resources, the schedule will then show 100%.   I have about 40 schedules with this characteristic.

    We are using 2007 professional on SP2

    #29243 Reply

    Caroline G

    I’m seeing that randomly and without budget resources. Rather annoying!

    #29256 Reply

    Jerry Insall
    Participant

    I know it can happen when a resource is assigned to a roll-up task in the schedule, but you can only apply a budget resource to the zero level task.

    #29273 Reply

    Jack Fox

    Do you possibly have any Milestones under the O level that are not statused? Milestones don’t affect summary levels, at least in my experience.

    #29355 Reply

    Jerry Insall
    Participant

    Jack, no all tasks and milestones are statused 100%.  Also, most schedules do not have detailed tasks at Outline Level 1 (only roll-ups) and all roll-ups show 100% except for the zero-level.

    #29384 Reply

    Mark Wells

    We use MS Project 2007 Pro and I had this happen to me today.  There are resources assigned to the tasks, at least most of the tasks but they are placeholder resources and I don’t think they are the problem,  I did not have time to really investigate, so I just over typed the % Complete column on the summary tasks and let it go.

    #277693 Reply

    David Rae

    I have seen this and have found a solution, although I don’t understand the reason it is occurring. If you look at the “Actual Finish” field it shows as N/A. If you set this date the 99% changes to 100%.

    #410141 Reply

    Alejandro Mejia

    David Rae,

    That just solved this same problem to me, don’t understand why though.

    Thanks!

    #411057 Reply

    Alan JK

    I’ve fixed this. I removed the allocation of resource at the top level and only applied resources at each individual task – as soon as I removed the resource at the top level the value when to 100 % and the Actual Finish date populated correctly.

    #411082 Reply

    Our organization is running MS Project 2013 Server and we used to see this scenario A LOT and we found many different reasons that caused it. Unfortunately, we aren’t using Budget Resources so I can’t comment on that. We did however assemble an FAQ on this topic, the basic content of which I’ve inserted into this reply, minus the screen captures which can’t be added to this response. Note that it references a couple views, and while you don’t have those views, the basic process should still be usable.
    ==========FAQ Content=========

    You can close a task by setting the task’s Remaining Work field to zero (0). When you do this, MS Project should update the % Work Complete field to 100% and also populate the Actual Finish field on the task. The steps for doing this are:

    1.In PRO, click the Task Tab on the Microsoft Ribbon.
    2.In the Properties section of the ribbon, click Details to display the Task Details Form.
    3.Right click in the grey area of the Task Details Form and select Work.
    4.Set Remaining Work Field to zero for each resource on the selected task.
    5.Click OK to save the changes. This should upate the task to 100% complete and assign an actual finish date. The actual finish date will be the date that actuals were last applied by any resource through the timesheet.

    Due to the manner in which MS Project treats resources that have not charged actual hours to a task, it is highly recommended you zero out the remaining work at the task assignment level (in the Task Details Form) as opposed to the task level at the top of the view.

    What if this does not work?

    MS Project has some quirks around closing tasks. There are several scenario dependent alternatives that can be tried if the process noted above does not result in a completed task. For these scenarios, we recommend using the EPMO Not Completed Tasks view which already contains all the fields referenced in the following processes.

    •An assigned resource(s) have 0 actual work.
    If you elect to zero out the remaining work at the task level (top of view) and MS Project does not automatically update the task to 100% complete and assign an actual finish date, it may be because one of the resources on the task did not charge any actuals. In this scenario, you should be able to simply remove the resource assignment from the task. To do this, click on the name of the resource in the Task Details Form (bottom of split screen) and click the Delete key on the keyboard to remove the individual from the task. Then, click OK to save the change. This should update the task to 100% complete with an actual finish date. Removing the resource will not impact your baseline.

    •An assigned resource does not show an actual finish date, but has 0 remaining work.
    This scenario often occurs on tasks with multiple resources assigned. While most resources will show an actual finish date, the resources causing the issue will show “NA” in their actual finish date.

    ◦For each of these resources on the task (there may be multiple), at the assignment level, give them 1 hour of remaining work. Click off the resource assignment row or hit enter to ensure the change is applied. Then remove the 1 hour just assigned, setting remaining work back to 0.

    ◦If the prior process doesn’t work, give each resource showing “NA” in their actual finish date 1 hour of remaining work. Then at the TASK LEVEL, set the remaining duration field to 0.

    •The task contains only local resources.
    If the task only contains local resources such as “Web Developer”, you should be able to close the task much like a milestone, using the 100% Complete icon in the Task ribbon. Warning. If the local resource has remaining work and you click the 100% icon, any Remaining Work will be transferred to Actual Work. Therefore, remove any Remaining Work first ,then click the 100% Complete icon.

    When a task has zero remaining work and the % Complete is still not 100%:

    Check the Remaining Duration of the task. If it is greater than zero, try changing it to zero or delete the value and have Project recalculate the field. If these do not work, check to see if the Task Type is Fixed Duration. If it is, try changing the Task Type to Fixed Work. If neither of these work (generally due to a “would change protected actuals” error), try changing the Task Mode of the task from Auto Schedule to Manual Schedule. This will generally zero out any remaining duration. Change the Task Mode back to Auto Schedule to ensure the task dates summarize correctly. CAUTION: Microsoft reports a possible bug exists when doing this – your actual hours may change when you toggle the task mode value back and forth. Note your actual hours prior to doing this and if they change, use the undo to remove the update.

    Note: Tasks do not behave like milestones.

    All Assigned Resources Show 100% Complete, but the Task itself Won’t Complete

    In this scenario, all assigned resources show 100% complete, have an Actual Finish date, and show 0 Remaining Work. However, the Task itself will not change to completed. One symptom of this scenario is the Task level fields % Complete (a duration based calculation) showing a value of 0%, Actual Duration showing 0, and Remaining Duration showing a value the same as the Duration field.

    The problem is an incorrect Option setting.

    To correct this scenario,

    1) Go into the Schedule Options window (File > Options > Schedule). Scroll down to the “Calculation Options for this Project” section and make sure the “Updating Task status updates resource status” option is checked. Save and return to the schedule.

    2) Using a view such as EPMO – Not Completed Tasks, locate the problem task. It will still reflect the problem since we need to change something on the task to force a Task level update. When trying to close a task early, the task type should be set to fixed units prior to removing remaining work. This will allow the task to be assigned an actual finish date and show % complete as 100%. On any resource assignment, change the Remaining Work to 1 hour. Click off the field and you should see the Task % Complete change to something like 99%. Set the same Remaining Work field back to 0. The Task should now show 100% complete.

Viewing 10 posts - 1 through 10 (of 10 total)
Reply To: 99% completed project when all tasks are 100%
Your information:




8 + 2 =