MSProj 2007 Prof: resource pool and project linkage/calculations problems

Home Forums Microsoft Project Discussion Forum MSProj 2007 Prof: resource pool and project linkage/calculations problems

Viewing 2 reply threads
  • Author
    • #4970
      Avatar photoCommunity

      I’m researching the viability of using MS Project Professional 2007 for a long term program and agency to do the following

      1. Use a shared resource pool and link projects the shared resource pool

      2. Create a Master Subproject linkage folder  at the end of each month for reporting purposes.

      Note: I’m also developing standards and training for the PMs to use MS Project 2007 Professional (They do NOT want to migrate to 2010 for at least a year).

      I have MS Project Professional 2007 with SP1 and SP2 installed.

      I’m following all of the directions, all of the rules, –and am having the following problems.

      * mpps won’t relink to the resource pool,

      *the resource usage view has a number of duplicates so leveled resources in the Gantt show they are overallocated in the resource usage view.,



      This is what I did yesterday. (and I made copies of folders to reserve each major step).

      1. I’ve created a resource pool, and added the following resources:  bob, carol, ted, alice, larry moe and curly

      2. Created three small project mpps  “bigbuy” “bigdoc” and “bigplan”  with about six summary tasks and 14 tasks  all identified so I would know which was which  (bb1.2  vs bd1.2)

      3. linked them to the resource pool

      4. Opened each of the mpps and assigned resources to the tasks (making them overallocated so I could teach leveling).  Each time I opened an mpp I MADE SURE I got the “Open Resource Pool” information.  And if everything was closed, when I opened the mpp, it also opened the resource pool. (good).

      5. Checked the resource usage and everyone was WAY overallocated (good).  I could also see (in any of the mpps) WHO ELSE was using “my” resource, by adding the “project” column.  Also good, what I hoped and expected to see.

      6. Next step:  Manual leveling.  Went into each of the mpps (all set to “unit” priority in the options section).  I reduced units (which extended the durations) and put some lags in.  I made sure that Bob was manually leveled among all three mpps.

      7. THEN—when I went back into the Resource Usage……. BOB was still at 52 hours for Monday!!    AND, there were “duplicates” of the same task assigned to Bob.  BB1.2  and BB1.2.   I also went into the Resource Usage Unassigned and there were Tasks showing unassigned that were also showing assigned to Bob!!

      8. After looking at various views of the resource usage through the mpps and the resource pool and seeing all of the inconsistencies in the hourly usage numbers….. I gave up and went home.


      Today.  I opened “bigbuy” and got the “open resource Pool” window (good) but when I did, I get: “MS project cannot find the. (file name path) Resource Pool.”


      So I closed Bigbuy, opened up resource pool (read only) and go back to big buy, open it up (get the open resource pool) click it, still can’t find the resource pool.   So I relink it back to the resource pool  Tools….share resources window—confirm it’s right, hit OK.  Wouldn’t link (didn’t get the Save resource window when I save–and got the error message again when I reopened it.…. I opened the other two projects and got the same results.

      When I hit save, the “save resource window does NOT show up…”  AND in the Resource Usage view of the mpps all I see is “their” tasks (not the others) (but the Resource pool shows everything) but the numbers don’t add up.

      So as of now….

      * I can’t relink the projects to the resource pool,

      * The Resource Pool shows a number of the BigBuy tasks are duplicated for each resource—but Bob is down to 4 hours in the resource pool…(Hes supposed to be 2, but he has a duplicate….

      * There are other issues…….


      1. Do you see anything (based on the steps listed above) that I did that was wrong?

      2. Are resource pools and linked projects ALWAYS this fragile????

      Any assistance you can provide re: relinking the projects to the pool or other direction would be appreciated.  I DID NOT MAKE any changes to the mpp once I opened them and found I lost the link (other than “saving” the relink process).

      Thanks in advance for your assistance.  You can email me at   Thanks!!



    • #6360
      Avatar photoCommunity
      Things like this are usually a small issue that produce big problems.  Normally, I have no trouble with resource pools using them pretty much as you describe.
      It will be much easier to look at the file than to flog this with email.  Might you be able to post the files (zip them all together)?  If not, let me know and we can do it privately.
      Jim Aksel, PMP, PMI-SP, MVP
      MS Project Microfosft Most Valuable Professional
    • #6364
      Avatar photoCommunity
      Jim (and Larry Christofaro):
      Jim– Larry helped me out Friday, and I didn’t have time to post the solution.  I just want to THANK YOU ALL for taking your time to provide assistance and the benefit of your experience.  This has been extremely helpful.   As promised, here is the "solution" that has worked for me, and if someone has better solutions, please let me know.
      Here’s the rest of the post.

      Problem:   I didn’t know that MS project, in essence, “hard codes” the path linkage among the resource pool and mpps.   Here are the rules as I understand them: Once you create a resource pool and subproject links:


      1. Leave them all in the same folder.
      2. Do NOT copy or move
      3. Do NOT rename any of the mpps.


      Solution:  But what if you “have” done one (or more) of these things?  (such as copy a folder from another location).  This is what I found to help in troubleshooting and fixing these mistakes..


      1. Troubleshooting. When you open a subproject, (eg: located in “5. Link Folder”)and you get an error indicating your subproject can’t find the pool.  Confirm by doing the following:
      2. Go into the resource pool and open it read only.
      3. Click Tools/resource sharing/share resources— and you will very likely see a number of mpps attached that are NOT in the “5. Link Folder.”  DON’T DO ANYTHING.  Leave the resource pool open “read only.”


      1. FIXING: Now open each of your subprojects, starting with the subproject that didn’t work.   Go to Tools/resources/sharing/share resources—and click on the scroll down arrow.  You will “likely” see “two versions” of the resource pool.(because of the multiple paths). Click the BOTTOM one, and click Save.
      2. Do this for each of the subprojects that are linked to the resource pool.
      3. Click save for each and then close.


      1. Close Resource Pool (read only) and reopen (in change mode).
      2. Go to Tools/resources/sharing/share resources- and you will see a number of duplicate files in different folder.  You only want to keep those projects who are in “5.Link Folder” and delete the rest. 
      3. To delete a bad link, Click the bad link, the select “break link.”  Repeat until all but the “good links” are there.
      4. Check the list to see that all of the “good subprojects” are linked as well.  If not, go into the ones that aren’t and add them.
      5. Of course, reopen EACH subproject to see—that it is linked to the pool, and that you can save and update

      Once I fixed everything, the anomalies disappeared, and the "math worked" just fine….


      THANKS again for assisting (and volunteering to assist)–
Viewing 2 reply threads
  • You must be logged in to reply to this topic.