Loading...
Quick Links

Close Tasks to Updates

Home Forums Discussion Close Tasks to Updates

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #5301 Reply
    Community
    Keymaster

    I’d like old, closed out projects to NOT display on the list when users insert/create tasks when doing timesheets. The old projects have had all remaining work turned to zero & tasks publish set to “No”.

    I found info on Closing Tasks to Updates: Settings>Server Settings>Close Tasks to Update>select a project>select all to Lock every task (including row 0)>Publish.  However after doing this for an old project, the project is still available to choose tasks from when doing a timesheet.

    Am I missing a step? Seems like you should be able to not display old projects when doing timesheets.

    #7071 Reply
    Community
    Keymaster

    Your’re right, that project shouldn’t appear on anyone’s timesheet.

    I suggest you double-check that the project has ALL tasks closed to update.  The UI for this feature can trick you.

    If your project has a large number of tasks, they are displayed in a series of pages (see the page control at the bottom of the list).  Choosing Select All” ONLY SELECTS THE TASKS ON THE DISPLAYED PAGE.

    You have to choose Select All for each page of tasks, and then click the Publish button.

    #7072 Reply
    Community
    Keymaster

    My gut feeling is that you cannot do this.  Close tasks to Updates stops status being applied to a task, but does not stop a timesheet line item being created.  Task statusing, and timesheets, are separate entities, and it seems that MS haven’t got around to developing a method to stop this scenario – it will need to be managed by training and reporting.

    #7073 Reply
    Community
    Keymaster

    I agree with Tom that project tasks should not appear on the timesheet if publish is set to no for all tasks. If you are on 2010, then you can also close the project summary task via close task to update. Project Server 2007 doesn’t allow you to prevent the project summary from showing on timesheets. Something seems to be amiss.

    #7074 Reply
    Community
    Keymaster

    Thanks for the responses.  I took a closer look at the particular project that I was testing with and the tasks weren’t set to publish No” — not sure how that got missed, but I was using a bad example.  However, I tried the test again with a project that DID have all tasks set to publish “No”, and still can’t get the project summary task/row 0 to not display on my timesheet list.

    I have Project Server 2010.  All tasks are set to publish No in the plan, I close tasks to updates (including row 0) using Server Settings>Close Tasks to Update>Select the project>lock all tasks on all pages (using the page control at the bottom of the list)>publish.

    The project name is still available in my timesheet — though there are no tasks to pick from.  However if I’m creating a task, I can simply pick the old project from the timesheet list and create a task for it.  If I then accept the new task as Status Manager (because I didn’t pay attention to the plan name), I’ve now added this task to the plan and made it available as an unlocked task (in a plan with row 0 & all others tasks locked) — and it can be used for time reporting.

    Though it seems like locking row 0 to updates should do the trick, it doesn’t hide the old project name, or prevent a timesheet line item from being created in our 2010 enterprise environment.

    Thanks for all the feedback!  At least I feel like I’ve tested it all I can:).

    #7075 Reply
    Community
    Keymaster

    Laurel,To close the project summary task (top level task in the timesheet), you need to select task 0 in the close task to update and then publish. It seems like you’ve done this and it doesn’t work. Is this a problem with just this one project or all projects?The ability to add a task to a project is user permission that you can turn off if you want (create new task or assignment). This assumes you aren’t using this feature as a normal process with real projects.I don’t have any other suggestions for why the close task doesn’t work for the top level task.Larry

    #7076 Reply
    Community
    Keymaster

    I did follow the procedure selecting row 0 & all tasks for another project — no change.  This doesn’t work for us on all projects.

    We do allow our developers to create new tasks in real projects in their timesheets as a normal process so that can’t be turn that off.

    Close Task for Top Level Task doesn’t work for us in our Project Server 2010 environment. It would be helpful to know if it does work for anyone else in their Project Server 2010 environment (bug or some problem in our environment?).  Thanks much, Laurel

     

     

    #7081 Reply
    Community
    Keymaster

    Laurel,

    Just Curious …

    In the Server Settings / Timesheet Settings and Defaults page there’s a section named Timesheet Policies.  One checkbox that I have NOT checked is Allow top-level time reporting.

    What’s your setting?

    #7082 Reply
    Community
    Keymaster

    I have the same setting as you — I do NOT have Allow top-level reporting” box checked as we don’t want resources to report time against top level items (however I just unchecked that box a couple weeks ago when I found the setting — at the same time I was trying to close tasks to updates).

    #7084 Reply
    Community
    Keymaster

    We figured out the problem… Closing Tasks to Updates works just like it should in our Production environment, but it doesn’t work in our Development environment (though not sure how to fix that yet).

    We copied of our EPM Prod data & settings to our EPM Dev environment a couple months ago (to have more recent info in Dev), and it turns out that there are things pointing to the wrong place now in our EPM Dev.  Tasks from EPM Prod flow to our EPM Dev timesheets in error, and Dev projects won’t close locked tasks to updates. We need to figure out how to re-point some things in EPM Dev.

    #7097 Reply
    Community
    Keymaster

    Sorry for any confusion in this string of posts, but I eventually found that Closing Tasks to Updates didn’t work for me because I was doing it in our EPM Dev environment and later discovered that we have issues with our EPM Dev environment that need to be fixed.

    This feature does work in our EPM Prod enviorment when I follow these steps:

    All tasks are set to publish No in the plan, and then I close tasks to updates (including row 0) using Server Settings > Close Tasks to Update > Select the project > Lock all tasks on all pages (using the page control at the bottom of the list) > Publish.

    Thanks to all for the tips!

    #9639 Reply
    Community
    Keymaster

    Try changing the Resources from Committed to Proposed for a given project and then publish the project. This will remove tasks from Resources’ timesheet.

    #9640 Reply
    Community
    Keymaster

    This is clearly a system bug———— it was supposed to have been addressed in MSP2010.  Just because work arounds can be implemented doesn’t mean it is a bug ———- however, you can also create a security group and move completed projects into that group and restrict everyones access but the admin or project office group.  This will help both in the timesheet add line drop down list and also in the PRO retrieve from list selection dialogue box.

Viewing 13 posts - 1 through 13 (of 13 total)
Reply To: Close Tasks to Updates
Your information:




66 + = 71