Loading...
Quick Links

Problems using Single Entry Mode in Project 2010

Home Forums Discussion Problems using Single Entry Mode in Project 2010

  • This topic is empty.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #2149 Reply
    CommunityCommunity
    Keymaster

    We’ve just migrated from Project Server 2007 to 2010 (we also previously used 2003).  We are using Single Entry Mode because the Timesheet System in 2007 was troublesome for us.  Resources often forgot to import Timesheets in My Tasks, or forgot to send Task to Project Managers for approval, and data then did not update Project Schedules.

    Single Entry Mode seems to have introduced a new issue  for us…resources are seeing lots of tasks they don’t see by default in the timesheet.  They can’t remove task, the ‘Remove Task’ button is disabled for many of these tasks. In Timesheet Settings, we’ve chosen the ‘No Prepopulation’ option.

    We’re currently going through schedules and changing non-needed Tasks to ‘no’ in the publish column.  However some of the tasks are needed (eg support or overhead type tasks).  We have many of these type of tasks.

    I’d appreciate any tips or advise.

    #6561 Reply
    CommunityCommunity
    Keymaster

    Still a bit confused if you could kindly provide additional information:

    * Tasks that do not allow a Remove Task is a good question.  Where are these coming from?  Are they tasks from real plans?

    * You say you’ve chosen No Prepopulation.  Are you seeing tasks even with this option chosen?

    * Why are you changing task publish flag to No for tasks that you want to keep on user’s timesheet?

    * Do these tasks look different than other tasks?  Are they personal tasks or show some other unique behavior?

    The timesheet populates tasks that are active for the week of the timesheet and tasks that are in process, but only when the populate option is set to Current task assignments.  Please provide additional information.

    Thanks…Larry Christofaro

    #6582 Reply
    CommunityCommunity
    Keymaster

    I use single entry mode and find it far better than the My Timesheet method where more is required of the resource to simply record time.  If you instruct the resources to use the filter and group-by selections in the ribbon, then they can control what they see.

    Tom

     

    #10276 Reply
    CommunityCommunity
    Keymaster

    Thanks for getting back to me Larry.  🙂

    I’ve learnt a few more things since the original post…but still think single entry mode is confusing, not quite what I expected, and I’ve had to put some work arounds in place.

    We have two types of tasks in our organisation: 1) Project type tasks – ie work required to deliver a project such as ‘Develop software’; and 2) BAU / Support / Administration type tasks – ie BAU type work such as ‘Support Application X’ or ‘Support Application Y’.

    Our problem lies not so much with tasks that form part of a project, because our Project Managers manage their schedules and update details.   The problem rests with with BAU / support / administrative type tasks.  We have over a hundred of these (a lot I know and we are looking to rationalise these over time).  Resources book time against these latter tasks on ad hoc basis.   I found that when many staff opened up their timesheet, they would have over a page of these support / administartive type tasks appearing by default.

    All our tasks (project and BAU tasks) are created via a Project Schedule. We have separate projects created for different types of BAU activity.

    Initially the guys were using the ‘remove task’ button to ‘hide’ unnecessary prepopulated tasks from appearing in their timesheet.  I’ve since learnt that we should never use this button because it has the effect of permanently removing the resource from the task.  It has already caused us problems because staff misinterpret the button and then can’t book to a task they later need. In 2007, a similar button did not seem to have such an adverse result, it only removed the task from appearing in the Timesheet.

    I’ve also instructed our Project Managers to unpublish tasks (ie setting status to no in the publish column in MS Project)  to prevent the task from prepopulating in the Timesheet view.  This reduces the number of tasks appearing in their Team Members timesheets. If a resource wants to book time to the task, they select insert row and then insert task, before navigating to the appropriate task.  The behaviour I’ve observed is that tasks will appear in the Timesheet by default under the following conduitions:

    1) If there is work scheduled for the Timesheet Timeframe Period

    2) if work has commenced on the task, and there is no work scheduled for the Timesheet Timeframe Period, but there is remaining work.  This effects long duration tasks such as umbrella tasks.

    The only time Tasks don’t seem to appear by default is if a) the Task starts after the Timesheet Timeframe period, or b) remaining work is equal to zero.

    Our BAU tasks are long duration tasks and that’s why they are appearing in the Timesheet.  We’ve now set remaining work on all these tasks to zero so they stop appearing in the Timesheet.  Unfortunately this will prevent us from setting up forecasts against these tasks in the schedule.

    If you have any suggestions on how we can better manage the BAU tasks that would be great? 🙂

    Some answers to your questions…

    All Tasks come from real project plans.  I don’t know why the Remove Task is disabled for some tasks and not others.  However, I’ve now instructed everyone to never use this button and we’re looking at introducing custom code to permanently disable it due its negative consequences.

    We are seeing Tasks even though No Prepopulation is selected.  I’ve been advised that Single Entry Mode combines  the views of Timesheet and Task views.  My hunch is that the No Prepopulation setting only applies to the Timesheet View and the reason we are seeing prepopulated tasks is due to the Task view component.  My preference would be to really have no prepopulation as the guys really do not like to have irrelevant tasks appearing and ‘clogging up’ their timesheet and they can no longer ‘hide’ tasks.

    We are only changing the task publish flag for tasks that have not started or are complete. This is so they do not prepopulate the tiemsheet.

    We only use two types of tasks: standard project tasks and administrative tasks.

    Thanks for your help. 🙂

Viewing 4 posts - 1 through 4 (of 4 total)
Reply To: Problems using Single Entry Mode in Project 2010
Your information: