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Objectives

Describe the importance of sequencing activities when building a
project schedule

Define Precedence Diagramming Method
Differentiate two methods of linking between projects
Define master project

Demonstrate linking activities across two projects using master
project and subprojects
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Project Schedule Management Knowledge Area
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Processes required to ensure timely project completion
- Plan Schedule Management

- Define Activities

- Sequence Activities

- Estimate Activity Durations

- Develop Schedule

— Control Schedule

Project Management Institute, A Guide to the Project Management Body of Knowledge, (PMBOK® Guide) -
Sixth Edition, Project Management Institute Inc., 2017, Pages 24-25
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Sequencing Activities

Sequencing activities and milestones with logic is the foundation
of any schedule model

The method of connection is defined as a relationship

Every activity and milestone, except the first (with no predecessor)
and the last (with no successor), should be connected to at least
one predecessor and one successor

Considered best practice in GAO Schedule Assessment Guide and
DCMA 14 point schedule assessment

Graphic adapted from Project Management Institute, A Guide to the Project Management Body of
Knowledge, (PMBOK® Guide) -Sixth Edition, Project Management Institute Inc., 2017, Page 23
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Sequencing Process
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Precedence Diagramming Method (PDM)

lllustrates assumed work tasks and expected relationships

- Finish-to-Start A

FS

- Start-to-Start =

- Finish-to-Finish

- Start-to-Finish

B
Use a network diagram to
B accurately reflect a project’s
== event sequence
B
SF| »

MP®G

Graphics adapted from the Project Management Institute, A Guide to the Project
Management Body of Knowledge, (PMBOK® Guide) - Sixth Edition, Project
Management Institute, Inc., 2017, Page 190.
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Develop Schedule

Once tasks are sequenced and the activity durations are estimated
the schedule is built

Microsoft Project allows many ways to link the tasks in the schedule
- Typing the dependencies directly into the Predecessor field

- Using the Predecessor/Successor table in the task form

- Manually select tasks, clicking the Link Tasks button in the Task ribbon
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Linking Task Across Multiple Projects

Situations where linking across multiple projects may be needed
- Handoffs

= One project can’t start until another one has completed so the respective
start and finish milestones are linked

= Software development does not start until requirements are complete
- Task completion is dependent on task completion in another project

= The manufacturing of the cockpit of a plane from one facility is dependent
on the manufacturing of the navigation system from another facility

= Each has a project schedule and these two tasks are linked

— Start and Finish of a Program consisting of two or more projects
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Methods of Linking Multiple Projects

Using Task Information dialog

— Ensure files are in same directory

- Double-click task to be linked to open Task Information Dialog
- Select Predecessor tab

- Manually type project name/task row number in ID column

Directly into the task fields

- Manually type project name/task row number in the Predecessors or
Successors field

Using a master project with subprojects
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Master Projects and Subprojects

Master projects

- Provide a project framework for the subprojects

— Connect individual subprojects together

— Contain the overall project flow and major milestones

Subprojects

- Detailed component projects individually managed and independently
maintained

- Become component and summary tasks of a master project
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Recommended Subproject Link Methods

Always use milestones in the master project to link tasks in two or
more subprojects

- Subprojects are easier to maintain without affecting the master project
- Keeps subproject transition in front of the program manager

-—l Master Project l—»_
/ / /. /.
Milestone v v
. I . I
] N
] ]
Sub Project 1 Sub Project 2
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Master Project Contents

Meetings and major milestones for project
Contractual deliverables
Non-contractual deliverables

Handoffs between subprojects

Program LOE tasks
-—l Master Project l—»_
4 a ¥ @ [
/ / / /
Milestone ! 4
- I _— I
] ]
] N
Sub Project 1 Sub Project 2
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Subproject Contents

Major milestones “owned” by the subproject

Contractual deliverables “owned” by the subproject
Non-contractual deliverables “owned” by the subproject
Milestones for handoffs to other subprojects or the master

Technical tasks

Project LOE tasks
-—l Master Project l—»_
- a Y @ [
/ / / /
Milestone ! 4
- I _— I
] ]
] N
Sub Project 1 Sub Project 2
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Linking Tasks Using a Master Project Demo

Create master project
Insert subprojects

Create milestones

Link master project milestones with subproject tasks or milestones
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Insert a Subproject Into a Master Project

Step 1: Select the Project tab
Step 2: Select the task where the subproject will be inserted

Step 3: Select Subproject in the Insert group

H ©- - Gantt Chart Tools  Master Project.mpp - Projec

Step 1: Select the Project tab
—— e ™ Tell me what you want {

File Task Resource

——— =

& e o B SR
F Store Ea T — :
5 e Bl = S
Subproject ﬂ My Add-ins = Project  Custom Links Between pities ! et bet Maove

g Infarmation Fields Projects Step 2: Select the task where ;.. - Project

the subproject will be inserted

nsert Add-ins Properties dule 4
< Start _ —
Step 3:Select  h a/e/1z / Add tasks with dates to the timeling
Subprojectin
the Insert group
Task Aug
0 Mode - | Task Name » | Duration - Start + Finish ~(|W | T|F |5 |5
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Insert Subproject

Step 4: Select a schedule to be inserted

Step 5: Click Insert

BE Insert Project .t
« « 4 M » ThisPC » Desktop v 0 Search Deskton 0
Organize = Mew folder == -
B This PC ~ Mame Date modified
10 Obiect Files Step 4: Select the Widget = . . . . AM
J Jects Project from the Desktop TeEE e
I Desktop @3 ABC Integration.mpp 2/10/2012 10:08 AM

e}

)

il

)
=
]

3

")

1

=

| Documents @3 Master Project.mpp

4 Downloads
J*.- Music

@3 User and Maintenance Guidefmpp 2/10/2018 9:09 AM
@3 WDC Resource Pool.mpp
[ Widget Project.mpp

e}

)

3

)

=)

2

2

]

1

=

(=]

& | Pictures

B Videos v £ Step 5: Click Insert >
Link to project

File name: | Widget Project.mpp o icrosoft Project Files (".mpp;™ ~

\
Toaols - Insert - Cancel
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Project Schedule Inserted

The inserted project file becomes a summary task

O = Gantt Chart Tools  Master Project. mpp - Project Professional
Task Resource Report Project [ Format ¢ Tell me what you want to do...
w o ’ = Status Date: [5] NA
p Store .I :Il = T | i — '
- u“-“: © =[] It Ef| Update Project
Subproject 3> My Add-ins - Project  Customn Links Between WEBS Change Calculate Set Mawve
Infarmation Fields Projects = Waorking Time  Project Baseline ~ Project
Insert Add-ins Properties Schedule Status
/211 WMon 8/20138
o |Aug‘|2, 18 |ﬁu.
= Start
— Maon 8/6/18
Task Aug s, '18
ﬂ Mode - | Task Name = | Duration « Start = | Finish - Predecess{| T | F |5 |5 | M | T
1 | - > Building the Widget IEH days Mon 8/6/18 Thu 9/27/18 b
\ " /
Information indicates
the task is an inserted Inserted project becomes a
project file summary task
&
<L
C
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Add Remaining Schedules

Insert the remaining schedules as subprojects

H ©- = Gantt Chart Tools  Master Project.mpp - Project Professional
File Task Resource Report Praoject i Farmat Q' Tell me what you want to do...
w o | F F - Status Date: E MA ABC
P Store .::Il =] T Nar: — | E '
— uﬁ‘-" - 2(f] It Ef] Update Project ¢
Subproject 3 Wy Add-ins ~ Pru:ujec!‘. Cl_!stcum Links E.Etween WES Change. CE|CI._I|EtE Se.t Mgve Spelling
Infarmation Fields Projects ~  Working Time = Project Baseline~ Project
Insert Add-ins Properties Schedule Status Proofing
= |Aug 12,18 |Aug19,"18  |Aug26,"18  |Sep2,'18 |Sep 9, 18 |Sep 16,18 |Sep 23,18 |Sep30,'18
= Start _ _ _
= Mon 8/6/18 Add tasks with dates to the timeline
=
T 3rd Quarter ath
'ﬂ' Mode = Task Name ~ Duration « Start  Finish ~ | Predeces| lu Aug | Sep | Oct
1 - > Building the Widget 36.13 days Mon 8/6/18 Wed 9/26/18
2 - - User and Maintenance Guide 50 days Mon 8/6/18 Mon 10/15/18
3 - - ABC Integration 43 days Mon 8/6/18 Thu 10/4/18
ke
Insert the schedules
=
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Enter the Milestones into the Master Project

Enter milestones above subprojects

Task 3rd Quarter ath Quarter
'ﬂ' Mode » Task Name ~ | Duration - Start - Finish - || lu Aug | Sep | Oct | Now
1 - Project Management Plan Completed 0 days n&/6/18 Mon 8/6/18 ﬂ B/6
2 - Preliminary Design Completed 0 days M¢n 8/6/18 Mon 8/6/18 ¥ 8/6
3 - Management Review 0 days M ) o o 8/6
. > ) g i Y 4 Add milestones to the :
4 ! Widget Delivered 0 days Mgn 3/ . 4 8/6
= master project :
5 | - User and Maintenance Guide Delivered 0 days = | n 8/brr—rrrerrororao 4 B/6
L 3 - - Building the Widget 36.13 days Mon 8/6/18 Wed 9/26/18 '
{IC A E - - User and Maintenance Guide 50 days Mon 8/6/18 Mon 10/15/18
L
E I E - - ABC Integration 43 days Meon 8/6/18 Thu 10/4/18
=
=T
(]
1 YU
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Link Between Master and Subprojects

Step 1: Expand each of the subprojects

Step 2: Select a milestone in the first subproject

Step 3: Use <Ctrl> and select the milestone in the master project
Step 4: Click the Link Tasks icon in the Schedule group

Gantt Chart Tools ~ Master Project.mpp - Project Professional

Format Q Tell me what you want to do...
= B X _ . L omoem == = \Mark on Track ~ a Inspect - L
I = D s - Calibri 11 0 25 S0z 782 100w  Respect Links h. % I Mover ol m
Gantt Paste i B I U - .EL - 5 5 sa @ch — nactivate S "L*. ; Lol Infarmation
Chatt~ = \ Step 4: Click the Link Tasks
View Clipboard Font [P} Schedule . . Propertig
. icon in the Schedule group prop—
Step 1: Expand eaCh Of 0 Mode «  Task Name w | Duration -« Start « Finish - Ju Aug  Sep Oct
the subprojects | - | Project Management Plan Completed ‘Lﬂ-days Mon 8/6/18  Mon 8/6/18 0 8/6
- Preliminary Design Completed 5 Mon 8/6/18 Mon 8/6/18 o 8/6
- Management Review 0 days Mon 8/6/18 Mon 8/6/18 0 8/6
4 - Widget Delivered 0 days n 8/6/18 Mon 8/6/18 0 8/6
5 User and Maintenance Guide Delivered 0 days Maon 18 Mon 8/6/18 ﬁ 8/6
5 (@3 - 4 Building the Widget 36.13 days Md™ T :
0 - partA s13days we Otep 3:Hold the <Ctrl> key and
- - . PartB 35.13days Tue Select the milestone in the
% -  Part C 21days  We master project
= - - > Final Assembly 9 days Thu'syis/1s wWed 9y 2of 1s ; L |
Step 2: Select the milestone in 4 Project Plan 2 days Mon 8/6/18 Tue 8/7/18 [| :
the subproject Project Plan 2days Mon 8/6/18 Tue 8/7/18 } Betty Smith[S0%]
o s~ Deliver Project Plan [0 days Tue8/7/18  Tues/7/18 +8/7
| B - User and Maintenance Guide 50davs  Mon 8/6/18 Mon 10/15/18 i
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Link Between Master and Next Subprojects

Step 1: Select the master project milestone
Step 2: Hold <Ctrl>, select the milestone in the second subproject
Step 3: Click the Link Tasks icon in the Schedule group

O - Gantt Chart Tools  Master Project. mpp
Resource Report Project i Format J Tell me what you
€ &D }{ Calibri In - E g % % ﬁ ﬂ Mark onTrack 2 3 % ?
Eg - L . %2 Respect Links =
Step 1: Select the master v B I U O-A- S5 (@A panually R |
project milestone pard Font 5 o Step 3: Click the Link Tasks
\o_\ask icon in the Schedule group
Mode - | Task Mame w | DUrrrrrr—— - e
2 | - | Project Management Plan Completed |D days Tue 8/7/18  Tue 8/7/1
4 - Preliminary Design Completed 0 days Mon 8/6/18  Mon 8/6/|
5 - Management Review 0 days Mon &/6/18 Mon 8/6/
6 - Widget Deliverad 0 days Mon 8/6/18 Maon 8/6/
Step 2: Hold the <Ctrl> key and - User and Maintenance Guide Delivered 0 days Mon 8/6/18 Maon 8/6/
select the milestone in the second '™ - Building the Widget 36.13 days Mon 2/6/18 Wed 9/2
subproject - 4 User and Maintenance Guide 52 days Mon 8/6/18 Wed 10/
= 1 \ 4 Develop User and Maintenance Guide 36.5days Mon 8/6/18 Waed 9/2¢
% 3 | - Guide Started 0 days Tue 8/7/18  Tue 8/7/1
“oq - Draft User Guide 20 days Wed 8/8/18 Wed 9/5
E 5 - Draft Maintenance Guide 5 days Thu 9/6/18  Wed 9/13




External Task Representations

Schedule dates in both the master and the subproject are impacted

Project Management Plan Completed
milestone scheduled to complete

based on Widget schedule i
Task Name = | Duration « Start w | Finish ~ Predecessors s —l W T
Project Management Plan Completed Links between projects i\ Users)\jbongiovani\Desktop\Widget Project.mpp\21 \ & B/7
Preliminary Design Completed show source file /6/18 1} &B/6
Management Review e—ererye S —— — Y 4@ &/6
Widget Delivered 0 days Mon 8/ Mon 8/6/18 0 8/6
User and Maintenance Guide Delivered 0 days Mon 8/6/18 on 8/6/18 # 8/6
- Building the Widget |36.13 days Mon 8/6/18 WW9/26/18 5
4 User and Maintenance Guide 52 days Mon 8/6/18 Wed 10X417/18 :
4 Develop User and Maintenance Guide 36.5days Mon3/6/18 Wed 9/26/1 H
Guide Started 0 days Tue 8/7/18  Tue 8/7/18 C:\Users\jbongiovani\Desktop\Master Project.mpp\2 { 8/7
Draft User Guide 20 days Wed 8/8/18 Wed9/5/18 3
Draft Maintenance Guide 5 days Thus/af18  wed9/12/18 4
Cre:?te FITST Draft 5 days Thu 9/13/18 W_ed 9/19/18 5 Start User and Maintenance Guide
Review First Draft 2 days Thug9/20/18 Frigf21/18 ]
Preliminary Design Completed 0 days Mon 8/6/18 Mon 8/6/18 starts on 8/7/2018 ————
Create Final Draft 2.5 days Mon 9/24/18 Wed 9/26/18 7.8
- Print and Reproduce User and 15.5days Wed 9/26/18 Wed 10/17/18
Maintenance Guide
- ABC Integration 43 days Mon 8/6/18 Thu 10/4/18
i
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View External Links

Step 1: Select the Project tab
Step 2: Select Links Between Projects in the Properties group

D - Gantt Chart Taals Master

) Step 1: Select the Project tab
Task Resource Report Project view Developer rorrat wolel

+ [ i ] [

@ m Store |ﬂ| | | _I @ | -7|~ ” .;.l ﬁ
_ _ _ = Step 2: Select Links Between
Subproject | & piy Add-ins - Project  Custom Links Between “WES= pyojectsin the Properties group
Infarmation  Fields F'rujedx - "rrl.lrmrll__] TTTTeE FTOJELL DdSElTTy
Insert Add-ins Properties Schedulsg
Task

9 Mode « | Task Mame » | Duration - Start .

2 | - Project Management Plan Completed .|III' days Tue 8/7/18
4 - Preliminary Design Completed 0 days Mon 8/6/18
& - Management Review 0 days Mon 8/6/18
& - Widget Delivered 0 days Mon 8/6/18
7 - User and Maintenance Guide Delivered 0 days Mon 8/6/18
I-E * Building the Widget 36.13 days Mon 8/6/1
s @ - 4 User and Maintenance Guide 52 days Mon 8/6/1
. 1 -} 4 Nevelon Lser and Maintenance Guide  36.5davs  Mon &/6/18
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Links Between Projects Dialog

The Links Between Projects dialog displays details regarding
external links in the project

External Predecessors tab displays the tasks

Links Between Projects In Chlsers\jbongiovaniDesktop' M gst riasmmrrrrrT inother schedules that are predecessors to
tasks in this schedule
External Predecessors  External Successors
ID | Task | Type | Date % Comp| Differences |’*
2 Project Management Plan Co
Deliver Project Plan Fs Tue &/7/18 Links Between Projects In C:h\Users\jbongiovanitDesktop\Master Project. mpp *
External Predecessors  External Successars
D | Task | Type kS Comp| Differences ad
2 Project Management Flan Co
Guide Started F5 Tue 8/7/18 e Mone
External Successors tab displays the tasks in
Fathy other schedules that are successors to tasks
Help All in this schedule

The Predecessor task name, the date
for the task, and file name that

contains the task will all be displayed Al
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Summary

Insert subprojects into the master project
Add milestones to the master project

Link the master milestones with the subproject tasks and/or
milestones in the order of the desired sequence

Repeat process as many times as needed
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Questions?
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