Inactivate Task problem

Home Forums Microsoft Project Discussion Forum Inactivate Task problem

  • This topic is empty.
Viewing 15 reply threads
  • Author
    Posts
    • #4960
      Avatar photoCommunity
      Keymaster
      In some (but not all) of my schedules, the Inactive Task button is disabled.   I don’t see why it should be.   Has anyone else had this problem?   Suggestions on how to fix it?
    • #6324
      Avatar photoCommunity
      Keymaster
      Christine,
      Tasks that contain actual work cannot be inactivated.  Could this be the problem?
      Larry Christofaro
      Digineer
    • #6325
      Avatar photoCommunity
      Keymaster
      Hi Larry,
      Thanks for the reply.  No, this isn’t the problem.   It’s for all new tasks.   I’m assuming it’s something with my global template, as I can receive files created by other people, and that don’t have this problem.   And from one of those files I can create my own template that I can use that doesnt’ have this problem.   But I can’t fix the file created by default from the global template.
      I’ve tried comparing all settings in Options between a file that doesn’t have the problem and a file that does, and haven’t seen any differences.
      Christine

    • #6326
      Avatar photoCommunity
      Keymaster
      Christine,
      I should have known it wouldn’t be that easy.  Could the project be saved in a 2007 format?  Try doing a save as and save a problem project as a Project format (instead of Microsoft Project 2007).  The extention hasn’t changed but the format is different and recognizable to Project 2010.
      Hope that helps…
      Larry Christofaro
      Digineer
    • #6327
      Avatar photoCommunity
      Keymaster
      Hi Larry,
      Another good suggestion, but still not the cause.  I save by default to Project 2010 format, all the files are already in 2010 format, and none of these files has ever even been saved as Project 2007.
      Christine
    • #6328
      Avatar photoCommunity
      Keymaster
      Christine,
      Now moving to the realm of comical…:-).  One more try.  Could the projects that you are having trouble with have been created using Project Standard.  Inactive tasks are not available in Project Standard.  I only have the Pro version so I don’t know what happens if projects are created and opened between versions.  In my opinion it should work if you are using Pro, but I honestly can’t think of anything else.
      Keeping my fingers crossed…
      Larry Christofaro
      Digineer
    • #6329
      Avatar photoCommunity
      Keymaster
      Hi Larry,  Yet another good suggestion, but still not it (evidenced by the fact that I can create files from my own template that have the button, just not from the global template).
      I’m about to try uninstalling and reinstalling Project (again – it didn’t work before, but maybe 2nd time’s the charm).  I’ll let you know if that helps.
      Thanks for all your suggestions!
      Christine
    • #6330
      Avatar photoCommunity
      Keymaster
      Christine,
      Your global (assuming local global, not Project Server) sounds like the problem (reading more carefully might have helped but sometimes I’m too fast for my own good).  Try this first.  try replacing your global with someone elses global.  To access the global, go to ‘your user’ / AppData / Roaming / Microsoft / MS Project / 14 / 1033.  Rename the existing global and copy in one from someone else.  If that doesn’t work than reinstall.  The uninstall might not actually delete the global so uninstall, then check and delete (or rename the gloab), and then reinstall.
      Third time’s a charm…???
      Larry Christofaro
      Digineer
    • #6334
      Avatar photoCommunity
      Keymaster
      Larry,  I followed your advice, which was much easier than an uninstall and reinstall.   first I took someone else’s global template (that I know is good), replaced the current with the new one, and it didn’t work.   Then I took a template of my own that works when I create "new" using that template, renamed it and made it the global template.  Again, no luck.   Then I uninstalled and reinstalled Project, and STILL no luck.  I have a workaround (all new files are created with a template of mine that works), but it’s inconvenient.  This is very perplexing…….
      Christine
    • #6335
      Avatar photoCommunity
      Keymaster
      Christine,
      Sorry to hear about that and I can certainly understand the frustration.  You might try to install any updates to the product (but unlikely that will make a difference).  If you are still bound to find an answer I might suggest submitting the issue to the Microsoft Project forum:  http://social.technet.microsoft.com/Forums/en-US/projectprofessional2010general/threads
      Good luck…
    • #6336
      Avatar photoCommunity
      Keymaster

      have had this problem.  Thought I need to reinstall and then took off previous versions.  Finally, when I selected task by Row Number the inactivate button became active.

    • #6801
      Avatar photoCommunity
      Keymaster

      Do you still have the Backward Compatibility mode enabled on your project Server 2010.

      Check under Server Settings >> Additional Server Settings

      Inactivate feature is disabled when the BCM is enabled.

      Be careful about disabling the BCM, though. You CANNOT re-enable it once you disable it.

    • #10552
      Avatar photoCommunity
      Keymaster

      Christine,

      Did you ever solve the Inactivate Task Problem?  I recently migrated a large (3500 tasks) project from 2007 to 2010 Professional (2010 basic doesn’t have the “Inactivate” button or feature) and have had problems since.  Now that I’ve migrated, I can’t get Task Activate / Deactivate to work.  I followed the thread of your experience, but no one ever solved your fundamental problem.  The inactivate task button always grayed out.  2010 is a buggy beast.

      I created a dummy project and the function works fine – I can activate or deactivate tasks at will.  But, my Project files that were created in 2007 do not respond.  I find it frustrating that migrating a project over adversely affects the features.

      Can anyone enlighten me?  Thanks!  Todd

    • #10553
      Avatar photoCommunity
      Keymaster

      The only time I run into this if I’ve opened a file previously saved in a compatible format.  I actually just resave it as a Project file, don’t even have to close out, and the inactivate button is active. File, Save As, same name with format of Project; overwrite existing file.

      • #500620
        Trudy
        Guest

        This worked for me Thank you !
        The only time I run into this if I’ve opened a file previously saved in a compatible format. I actually just resave it as a Project file, don’t even have to close out, and the inactivate button is active. File, Save As, same name with format of Project; overwrite existing file.

    • #10554
      Avatar photoCommunity
      Keymaster

      Prasanna and AFridelle,

      Thank you both for responding.  I can’t imagine I’m the only one suffering from this, but I have not seen much traffic in the BLOGosphere.

      1. Regarding Backward Capability: I have MSP2010 Professional, but am not using PWA features on server.  Because the Inactivate Task (and Auto/Manual Schedule toggle) seems to work under some circumstances, I don’t think turning off the Backward Capability Mode should be necessary.  Do you agree?

      2. Regarding AFridelle’s comment: I agree that a legacy project file – say MSP2007 – should open in MSP2010 Professional and then I should be able to simply convert using SAVE AS an MSP2010 Project file.  I’ve manually SAVED AS the files anyway, but that didn’t fix my problem.

      3. I am open to suggestions.  I fear I must copy the projects into a working template, which will be a lot of work and possibly introduce corruptions in my data.  I have a MASTER and 12 SUBPROJECTS hammocked to that master with EXTERNAL links between the subprojects.  I’ll need to validate all that data.

      Keep the ideas coming!  And thank you!  Todd

    • #360006
      Shahid
      Guest

      Looks like only professional version gives you this option. I just checked, 2010 and 2013 standard version do not have this option. Professional version has this option.

Viewing 15 reply threads
  • You must be logged in to reply to this topic.