Home Forums Discussion Resource Leveling w/ Master Schedule & Sub-Projects & a Shared Resource Pool

This topic contains 6 replies, has 3 voices, and was last updated by  Jessica Allen 1 month, 4 weeks ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #412815 Reply

    Hi all,
    I use Project 2016 locally — no server or on-line. I have 13 sub-projects inserted into a master with all sharing a common resource pool. I configured the pool so that the pool has precedence. I entered users by selecting their Active Directory accounts.
    I am having an issue. Task1 is in one project and task2 is in another. I’ve assigned both to the same resource. Task 1 has the higher priority. There is no dependency between the tasks. The Master Schedule’s gantt view shows that task2 starts before task1 finishes. Nothing indicates that the resource is over allocated.
    I looked at resource usage and found that the task2 “starts” but has 0 hours allocated to the task up to the point where the first task finishes. This 0-hour entry apparently triggers the Start field to show an earlier date in the gantt view even though the resource isn’t has no hours planned.
    Is this normal?

    Thanks,
    Mark

    #412816 Reply

    Should I place the resources within the Master Schedule — or in a separate shared resources file?

    #412819 Reply
    Larry Christofaro
    Larry Christofaro
    Participant

    Robert, that’s a complex question that could be one or more of many causes:
    1. I assume all projects including the resource pool are open when resource leveling
    2. Do your projects all have the same priority? Project priority defaults to 500, which will then prioritize by tasks across all projects.
    3. Is “Leveling can adjust individual assignments on a task” selected and are there multiple resources assigned to the task in question.
    4. Check the predecessors on the two tasks. They don’t have to be predecessors to each other to have Project assign lower priorities first.
    5. Do you have Leveling Order set to Priority/Standard? That’s a must.
    That’s at least a start to check. Hope that helps…

    #412823 Reply

    Hi Larry,
    Thanks for the answer. I did have all the sub-projects open while leveling and all have a priority. I have assigned only one person to each task. Generally, that’s the way we operate, anyway. I went through the entire list of projects this morning and scrubbed the predecessors for each task. This still allowed a task to begin with the first few days have “0” labor hours. I’m not that experienced with project — but have never seen that before. Finally, I turned off leveling’s ability to create splits. That worked… I just don’t understand why.

    #412825 Reply
    Larry Christofaro
    Larry Christofaro
    Participant

    Well, you seem to have a handle on most things leveling so I give you credit. A couple of questions:
    1. Did you try clearing leveling and see if the assignment delay was maintained? That’s my first guess but I assume from our conversation that the answer is no.
    2. Could the task have had an actual start date? That would have locked the task start but still move remaining work as best as it could. I’m guessing the answer is still no, but it sounds like a potential result of turning off its ability to split tasks.

    I’ve run across situations where it’s difficult to assess. If you’re like me and doesn’t like to give u without an answer, I might suggest recreating that task and see if it has the same behavior. I’m grasping a bit, but I’ve used leveling enough to know that it works well within its rules (but I have found recreating tasks to be an answer in some cases).

    Again, good luck. Glad you found something that works.

    #412834 Reply

    Okay — I deleted and re-created the task and that seems to work. Don’t necessarily understand why — but that understanding is a nice to have as long as it works. We’re working a very critical timeline as we’re having to move out of a data center — and are very resource constrained. This schedule HAS to work. I’m grateful for your help.

    #412924 Reply

    Jessica Allen

    Deleting the task and recreating it probably worked because the hours (8 hours per day) were reset. What likely happened is that you were adjusting resources and/or durations and the hours automatically adjusted due to having a task type of ‘Fixed Work’ and/or ‘Effort Driven’ selected for the tasks. Insert the ‘Task Type,”Effort Driven,’ and ‘Work’ columns. All tasks with resources assigned will show the number of hours based on the duration of the task and how many resources are assigned (two resources for 2 days should be 32 hours, whereas one resource for two days would be 16 hours). If the tasks are ‘Fixed Work,’ when resources are deleted the duration will automatically adjust (i.e., what once took 2 days for two resources to complete will now take 4 days for one person to complete). Additionally, a fixed work task with a resource assigned will maintain the number of work hours once a resource is assigned (i.e., assign a resource to a two day task [16 hours] and extend the duration to 5 days – the 16 hours will stay the same). Similarly, if a task is effort driven, adding more resources to a tasks will automatically shorten the duration of a fixed work task.

    Our workaround to maintain control over the task duration and hours is to ensure tasks default to ‘Fixed Duration’ and are NOT Effort Driven. This gives us more control of our schedule to prevent automatic adjustments to durations and/or work (hours).

    If you insert the ‘Work’ column and see that things are not adding up for other tasks, simply delete the duration and reinsert it and that should reset it (when Project is behaving).

    Hope this helps explain things!

Viewing 7 posts - 1 through 7 (of 7 total)
Reply To: Resource Leveling w/ Master Schedule & Sub-Projects & a Shared Resource Pool
Your information:




76 − = 72